Eclipse, Maven and Spring DM for OSGi™ platform

Quick Start

Author: Oleg Zhurakousky (oleg.zhurakousky@gmail.com)

February 21, 2008
<table>
<thead>
<tr>
<th>Chapter</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Introduction</td>
<td>3</td>
</tr>
<tr>
<td>2. Prerequisites</td>
<td>3</td>
</tr>
<tr>
<td>3. Create and configure Spring DM project</td>
<td>6</td>
</tr>
<tr>
<td>4. Test Configuration</td>
<td>9</td>
</tr>
<tr>
<td>5. Set up project class-path dependencies (Maven)</td>
<td>11</td>
</tr>
<tr>
<td>6. Implement Spring DM service</td>
<td>15</td>
</tr>
<tr>
<td>7. Deploy Spring DM service</td>
<td>21</td>
</tr>
<tr>
<td>8. Eclipse PDE Tracing</td>
<td>24</td>
</tr>
<tr>
<td>9. Packaging Spring DM OSGi™ bundle</td>
<td>27</td>
</tr>
<tr>
<td>10. Testing</td>
<td>34</td>
</tr>
<tr>
<td>10.1. Unit Test</td>
<td>34</td>
</tr>
<tr>
<td>10.2. Spring DM client bundle</td>
<td>36</td>
</tr>
<tr>
<td>11. Logging (log4j)</td>
<td>41</td>
</tr>
<tr>
<td>12. Conclusion</td>
<td>46</td>
</tr>
</tbody>
</table>
1. Introduction

This tutorial attempts to introduce the developers on how to setup development environment for working with Spring Dynamic Modules (DM) for OSGi™ platform project using currently available tools based on Eclipse IDE, Eclipse Equinox OSGi™ container and Maven plug-in. And even though it does cover some of the details of OSGi™ as well as Spring DM is not aimed to be the tutorial for either. It is also not aimed to be an Eclipse or Maven tutorial For more information on OSGi™ and Spring DM please refer to the following websites

Spring DM - http://www.springframework.org/osgi
OSGi™ - http://www.osgi.org/Main/HomePage
Eclipse IDE – http://eclipse.org
Maven - http://maven.apache.org/

2. Prerequisites

This tutorial is based on Eclipse (Europa) 3.3.1 with Maven Plug-in installed.

You can download Eclipse here (if you don’t already have it)

If you already have Maven plug-in installed you can skip to the next chapter otherwise let’s install it.

Open up Eclipse. Click on Help (on the menu bar) → Software Updates → Find and Install → Search for new features to install → Next
We are going to add a new Update site

Click on New Remote Site

In the Name enter:  Maven Plug-in
In the URL enter:  http://m2eclipse.codehaus.org/update/

Click OK \rightarrow Finish

Expend Maven Plug-in and select Maven integration for Eclipse

Accept the license agreement and the rest of the defaults.
When wizard finishes downloading and installing plug-in it will prompt you to restart Eclipse. Do so.

Now you ready to continue.
3. Create and configure Spring DM project

In this chapter we are going to create a project for our Spring DM bundle.

Right-click on the white space in Project Explorer:
New → Other → Maven → Maven Project

Let’s call it **SpringDMBundle**.

Click Next → Finish
Right-click on the newly created project → **PDE Tools** → **Convert Project to Plug-in Project**.
Make sure it is the only project selected

![Convert Existing Projects dialog box]

Click on **Finish**

This will configure project as Eclipse Plug-in project which will add **META-INF/MANIFEST.MF** to the root of the project amongst other things.

Open up **Project Explorer view** (Window → Show View → Other → General → **Project Explorer**)

![Project Explorer]

You should see libraries for **Maven** and **Plug-in dependencies** there. We are only going to be using Maven for dependency management; however we’ve added Plug-in nature to the project simply because Eclipse PDE environment is an OSGi™ environment where
Eclipse plug-ins are OSGi™ bundles. This will allow us to use Eclipse provided OSGi™ Equinox container as well as other Eclipse infrastructure elements be able to deploy and execute Spring DM projects by right-clicking on the project → Run As → OSGi Framework

Don’t run anything yet!
4. Test Configuration

In this chapter we will test our configuration

Let’s Test it.
On the Menu bar click on Run → Open Run Dialog

Right Click on OSGi Framework → New
In the name enter: SpringDMConfiguration
Make sure SpringDMBundle is checked (you can un-check everything else)
Click on **Apply ➔ Run**
Eclipse Equinox OSGi™ container will start and the Console will show prompt like this:

```
> Enter “ss”
And you should see that your project is deployed and in the ACTIVE state.
```

```
> ss
Framework is launched.
```

<table>
<thead>
<tr>
<th>id</th>
<th>State</th>
<th>Bundle</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>ACTIVE</td>
<td>org.eclipse.osgi_3.3.1.R33x_v20070828</td>
</tr>
<tr>
<td>1</td>
<td>ACTIVE</td>
<td>SpringDMBundle_1.0.0</td>
</tr>
</tbody>
</table>

Obviously this bundle is useless since we didn’t write any code, but it is a valid OSGi™ bundle even though it has no relation to Spring or Spring DM.

So let’s add some meat to it.

You can kill the OSGi™ container for now.
5. Set up project class-path dependencies (Maven)

In this chapter we will use Maven to setup class path dependencies for our project.

First let’s modify our Maven POM file located at the root of the project.

Open pom.xml and paste the contents below into it (make sure to put it after description tag and before the closing project tag)

```xml
<dependencies>
    <dependency>
        <groupId>org.springframework</groupId>
        <artifactId>spring-test</artifactId>
        <version>2.5.1</version>
        <scope>test</scope>
    </dependency>
    <dependency>
        <groupId>org.springframework</groupId>
        <artifactId>spring-core</artifactId>
        <version>2.5.1</version>
        <scope>test</scope>
    </dependency>
    <dependency>
        <groupId>org.springframework</groupId>
        <artifactId>spring-context</artifactId>
        <version>2.5.1</version>
        <scope>test</scope>
    </dependency>
    <dependency>
        <groupId>org.springframework</groupId>
        <artifactId>spring-beans</artifactId>
        <version>2.5.1</version>
        <scope>test</scope>
    </dependency>
</dependencies>
```
Click **CTRL+Shift+F** to format the contents of the file.

This will define the required dependencies, repositories where to find those dependencies will be downloaded from and few packaging directions.
Save `pom.xml` file and build the project which for now will only install all the dependencies. To build it right-click on the project → **Run-as** → **Maven build**. Enter **install** as your Goal.

Click on JRE tab and enter `-Xmx128m` as VM argument. This is optional but on my machine it ran out of heap size so just to be safe.
Click on **Run**.

This will take a bit of time and will depend on the state of your local Maven repository. After successful build your Maven libraries should all be in your class path.
6. Implement Spring DM service

Now we are going to implement a service which we will deploy later on inside of Eclipse Equinox OSGi™ environment.
I am going to assume that the knowledge on how to create classes and interfaces inside of the Eclipse IDE exist therefore I am going to skip the details.

First create **FooService** interface

```java
package org.springdm.service;

public interface FooService {
    public void foo();
}
```

Then create **FooServiceImpl** class

```java
package org.springdm.impl;

import org.springdm.service.FooService;

public class FooServiceImpl implements FooService {

    public FooServiceImpl(){
        System.out.println(">>> Constructing FooServiceImpl");
    }

    @Override
    public void foo() {
        System.out.println(">>> Executing foo()");
    }
}
```

You should see something like this
Note that in the best traditions of Spring there is nothing Spring specific in these artifacts just a POJO and POJI. And as far as OSGi™ concern that is actually enough with the exception of OSGi™ Activator class that would bootstrap our service. Activator is responsible for lifecycle and registration of the bundle which means Activator usually contains nothing more then a boilerplate code that wires your bundle to OSGi™ container.

Writing Activator is outside of scope of this chapter or tutorial, even though when we get to the Test Client later on we will write a simple Activator for testing purposes. And for those who are interested in more details about Activator, there are plenty examples on how to do it available on the web.

What we want to do is a little more then just deploy an OSGi™ bundle. We want to deploy Spring powered OSGi™ bundle which means we are going to deploy Spring Application Context which need to be recognized somehow by OSGi™ container. We also want to register our POJO service as an OSGi™ service to make it available to other bundles within OSGi™ container.

Spring DM provides convinient infrastructure to do all that. First we are going to create Application Context definition file fooservice.xml and place it in spring directory under META-INF

```
<?xml version="1.0" encoding="UTF-8"?>
<beans xmlns="http://www.springframework.org/schema/beans" 
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
xsi:schemaLocation="http://www.springframework.org/schema/beans 
http://www.springframework.org/schema/beans/spring-beans.xsd">

  <bean name="fooService" class="org.springdm.impl.FooServiceImpl" />

</beans>
```

Nothing special, just a regular Spring bean definition.
We are going to create another Application Context definition file called `fooservice-osgi.xml` and place it in the same directory.

And here are the contents of this file:

```xml
<?xml version="1.0" encoding="UTF-8"?>
<beans
xmlns="http://www.springframework.org/schema/beans"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://www.springframework.org/schema/beans
http://www.springframework.org/schema/beans/spring-beans.xsd
http://www.springframework.org/schema/osgi
http://www.springframework.org/schema/osgi/spring-osgi.xsd">
  <osgi:service id="fooServiceOsgi" ref="fooService"
    interface="org.springdm.service.FooService"/>
</beans>
```

Note that we are using a `osgi` name space which will allow Spring DM (OSGIServiceFactoryBean in particular) to use Spring exporter infrastructure to export and register our service as OSGi™ service within OSGi™ container so it could be used by other bundles that might not be Spring enabled.

We could have place both definitions into a single file, but separating them makes testing (we’ll get to testing later) of POJO service functionality simpler since it doesn’t require OSGi™ specific dependencies and or Spring DM testing infrastructure.

More details on the deployment infrastructure of Spring DM bundles are provided in Spring DM reference documentation (Chapter 4), but in the nutshell here is what is going to happen when we package our bundle:

Once our Spring-powered OSGi™ bundle is deployed into OSGi™ container and brought up to the ACTIVE state, Spring DM Extender Bundle will recognize it and in the similar fashion as ContextLoaderListener loads Web Application Context will load Application Context defined in our bundle.
Then OSGi™ service defined in our `fooservice-osgi.xml` file will be registered within OSGi™ container by `OSGIServiceFactoryBean` as an OSGi™ service identified by the `FooService.java` interface which is how it is going to be known to the rest of the OSGi™ bundle. The actual implementation becomes internal to the Application Context. You can read more on Exporting Spring Bean as OSGi™ service in Chapter 5 of reference documentation.

Now all we need is integrate Spring DM bundles with Eclipse provided Equinox OSGi™ environment. In Eclipse terms we basically have to setup a Target Platform.

Appendix C of Spring DM reference documentation has a very comprehensive set of instructions on how to do that so I won’t be repeating it, so simply follow the directions there and once done come back.

Click on Window (menu bar) ➔ Preferences ➔ Plug-in Development ➔ Target Platform
Select Spring Dynamic Modules for OSGi™ Service Platform 1.0 as you target and click on Load Target ➔ OK
One of the best parts of OSGi™ is the fact that it takes us back to the basics, where Java programs are packaged into JAR files and MANIFEST.MF actually means something. So let’s update our MANIFEST.MF file and test our Spring-powered bundle. When you double-click on the MANIFEST.MF file it will be opened by Plug-in Manifest Editor which contains multiple tabs and property windows that will allow you to quickly assemble and/or modify your MANIFEST.MF file.

Below is view of the Runtime tab of our Manifest file.

As I mentioned before one of our goals is to export our service into the OSGi™ container so other bundles can use it and as you can see in Exported Packages I did just that by clicking on Add button.

Also for sanity check click on MANIFSET.MF tab to see plain text representation of Manifest. There you can see our exported service.
For now our Manifest is extremely simple and trivial. Other than Export-Package one other important property to point out is Bundle Symbolic-Name (a.k.a Bundle ID). It contains the name by which you would reference this bundle from other bundles when need to.
7. Deploy Spring DM service

The fact that your project has Eclipse PDE nature is recognized by PDE runtime environment and that is why you see it under Workspace bundles. This means that while developing there is nothing needs to be done to deploy the service. So let’s test it by simply starting OSGi™ Framework runtime environment.

On the main bar click on Run ➔ Open Run Dialog ➔ OSGi(tm) Framework ➔ SpringDMConfiguration. You should see a familiar window with the exception of Target Platform now being different since we picked Spring DM Target platform earlier.

Select SpringDMSERVICE and all of the bundles of Target Platform. We obviously don’t need all of them but for the sake of saving time we’ll just do a Select All.
Click **Run**. Your console should look like this

```
spring:log4j:WARN No appenders could be found for logger (org.springframework.util.ClassUtils).
spring:log4j:WARN Please initialize the log4j system properly.
>>> Constructing FooServiceImpl
```

This is it! You have deployed your first Spring DM OSGi™ service and the console shows that the service has been constructed. You can type “ss” in the console and you’ll see your service in the ACTIVE state.

But how do we know that our service was registered and other bundles can see and use it. In other words how do we know that Spring DM did its job?

Well, first of all if we open **Run Dialog** and uncheck **Target Platform** and run the service again
Our console output will look like this

And even though our bundle is in ACTIVE (check it by typing “ss” in the console) state our service was not registered as an OSGi™ service simply because we did not implement our own OSGi™ Activator inside our bundle nor did we use any framework (i.e., Spring DM) to do it for us.

By re-enabling **Target Platform** which in our case is *Spring DM Target Platform* our service will be constructed and registered.

On the other hand one might say that our `System.out.println` statement inside of the service constructor proves only that the class was constructed. It does not prove anything about service registration. And you are right. To do that we are going to use Eclipse PDE tracing facility which will output certain messages to the console that will show us service registration.

Later on we will also write a quick client bundle that will use our service.
8. Eclipse PDE Tracing

By now you should be familiar with Eclipse PDE in the scope of this tutorial so some of the details will be skipped.
Open up Run Dialog ➔ OSGi™ Framework ➔ SpringDMConfiguration
Click on Tracing tab
You should see the following:
Check **Enable Tracing**
Check **org.eclipse.osgi**
Check **debug/services**

Your settings should look like this

Click **Apply** → **Run**
You will see that your OSGi™ console will start spitting out tons of messages. 
Look for message similar to this:

```
......
ggetServiceReferences(null, "(objectClass=org.xml.sax.EntityResolver")
ggetService[initial@reference:file:../../../../../OSGi(tm)_workspace/SpringDMBundle/ [23]]({org.xml.sax.EntityResolver}={service.id=22})
>>> Constructing FooServiceImpl
registerService[initial@reference:file:../../../../../OSGi(tm)_workspace/SpringDMBundle/ [23]]
({org.springdm.service.FooService}={org.springframework.osgi.bean.name=fooService, Bundle-SymbolicName=org.springdm.service.SpringDMService, Bundle-Version=1.0, service.id=23})
......
```

Now you see that your service was successfully registered and available by the name 
org.springdm.service.FooService.
9. Packaging Spring DM OSGi™ bundle

Earlier while creating Maven pom.xml file we’ve added the following direction:

```xml
<build>
  <plugins>
    <plugin>
      <groupId>org.apache.maven.plugins</groupId>
      <artifactId>maven-jar-plugin</artifactId>
      <configuration>
        <archive>
          <manifestFile>
            META-INF/MANIFEST.MF
          </manifestFile>
        </archive>
      </configuration>
    </plugin>
  </plugins>
</build>
```

This should copy our META-INF/MANIFEST.MF file into the root of our package when Maven generates the JAR file which will be in target directory under root. To generate JAR package do the following:
Right click on the project → Run As → Maven install

Refresh your target directory and you will see SpringDMBundle Snapshot packaged as JAR file

```
src
|-- target
|   |-- maven-archiver
|   |   `-- SpringDMBundle-0.0.1-SNAPSHOT.jar
|   `-- build.properties
```
Using your favorite packaging utility un-JAR this file and look what is inside.

There is a problem. Even though META-INF directory does have the MANIFEST we asked Maven to copy, but it is missing `spring` directory which contains our ApplicationContext definition files.

There are several ways to fix it with Maven and/or Eclipse, but since this tutorial is centered on Eclipse development environment we will fix it using Eclipse provided functionality.

Right-click on the project → **Properties** → **Java Build Path**

Click on **Source** tab

The following window will open up
Click on Add Folder and add root of the project as source folder

![Source Folder Selection](image)

Click **OK → OK** (on the next window) → **OK** (on the properties window)

Your project should look like this:

![Project Structure](image)

Not out of the woods yet. You can see that **src.main**, **src.test** and **target** folders fell into Source category. We don’t want that so we have to exclude them. To do that we would need to add Exclusion filters to our build path.
To do that open up the same project properties window → **Java Build Path** → **Source**
Highlight **Excluded** under SpringDMBundle
Click on **Edit**. You should see the following window.

![Inclusion and Exclusion Patterns window](image)

In the **Exclusion patterns** click on **Add ➔ Browse ➔** and one by one add the following folders and files to the exclusion list:

- `src`
- `target`
- `.classpath`
- `.project`
- `build.properties`
- `pom.xml`

Click on **Finish ➔ OK**

Now your project looks just like before.
Build the project

**Right-click** on the project → **Run As** → **Maven install**

Refresh the **target** folder and unpack the JAR (just to verify)

You should see the following structure

Now we have a valid Spring DM bundle that you can deploy into any OSGi™ container.
10. Testing

So far we have created SpringDM OSGi™ bundle, deployed it, exported the service and were able to verify its creation and registration. We missed few things:
1. We did not test service functionality (however trivial it is)
2. We did not attempt to access our service from another bundle.

Spring DM provides a testing framework that will allow you to test your services without ever deploying them. The details on how to do that are very well covered in the screen casts available on Spring DM website. You can also look at the simple-service available with Spring DM distribution which has a very trivial example demonstrating Spring DM testing platform.

What we’ll do here is write a simple unit test to test functionality of our trivial service and then we’ll develop SpringDMBundleClient (another Spring DM bundle) that will use our service

10.1. Unit Test

The main purpose of the Unit Test within the scope of this tutorial is to demonstrate the strategy of testing Spring DM services independently from Spring DM and/or OSGi™ infrastructure.

If you remember we created two Application Context files where one was simply maintaining Spring Bean definitions representing our services while another one was using osgi namespace to perform post-processing (i.e., register our service as OSGi™ service)

The following Unit Test will test our service and its functionality as if it was a simple Spring Bean (cause it is)

Let’s create FooServiceTestCase
And here is the code

```java
package org.springdm.test;

import junit.framework.TestCase;

import org.springdm.service.FooService;
import org.springframework.context.ApplicationContext;
import org.springframework.context.support.FileSystemXmlApplicationContext;

public class FooServiceTestCase extends TestCase {
    private ApplicationContext ac;

    public void setUp(){
        ac = new FileSystemXmlApplicationContext("META-INF/spring/fooservice.xml");
    }

    public void testFooServiceFoo(){
        FooService service = (FooService) ac.getBean("fooService");
        assertNotNull(service);
        service.foo();
    }
}
```

Run it and make sure it passes

Also run Maven install (I assume by now you know how to do that) and you should see the following output.

```
INFO: Loading XML bean definitions from file
[C:\Spring\Eclipse\osgi_workspace\SpringDMBundle\META-INF\spring\fooservice.xml]
INFO: Bean factory for application context
[org.springframework.context.support.FileSystemXmlApplicationContext@1bc887b]:
org.springframework.beans.factory.support.DefaultListableBeanFactory@39e5b5
INFO: Pre-instantiating singletons in
org.springframework.beans.factory.support.DefaultListableBeanFactory@39e5b5:
defining beans [fooService]; root of factory hierarchy
>>> Constructing FooServiceImpl
>>> Executing FooServiceImpl
Tests run: 1, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.328 sec

Results :

Tests run: 1, Failures: 0, Errors: 0, Skipped: 0

[INFO] jar:jar
```
10.2. Spring DM client bundle

To make our example more exciting and useful let’s develop another bundle called SpringDMBundle Client. Follow the steps in Chapter 3.

You should come up with the following project

Open up META-INF/MANIFEST.MF file → Click on Dependencies tab → Add (on the Required Plug-ins) and add org.eclipse.osgi and org.eclipse.service.SpringDMService (our previous bundle)
Click OK. Make sure the entries were added to MANIFEST file by clicking on MANIFEST.MF tab

```
Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: SpringDMBundleClient
Bundle-SymbolicName: SpringDMBundleClient
Bundle-Version: 1.0.0
Require-Bundle: org.eclipse.osgi,
    org.springdm.service.SpringDMService
```

Now let’s create Bundle Activator which will be executed by OSGi™ container during initialization. BundleActivator interface defines two methods START and STOP.
We are going to implement START method where we will attempt to access our SpringDMBundle.FooService and execute foo() method.

Why are we doing it? Simply because we can and it is the quickest way to demonstrate how one bundle can access services exported by another bundle. It will also introduce you to OSGi™ API.

The use case for our START method will be simple. Locate FooService and execute foo() method.

Chapter 3.2 of Spring DM reference documentation states: “The extender bundle creates applications contexts asynchronously. This behavior ensures that starting an OSGi Service Platform is fast and that bundles with service inter-dependencies do not cause deadlock on startup...”. This means that even if we were to play with OSGi™ start levels we can’t rely on the fact that during initialization and activation of our client bundle our SpringDMBundle.FooService is registered, so we are going to loop 10 times or until service is located (whichever comes first). Once service is located we will retrieve it from the BundleContext and execute it. Very trivial example
Here is the code

```java
package org.springdm.client;

import org.osgi.framework.BundleActivator;
import org.osgi.framework.BundleContext;
import org.osgi.framework.ServiceReference;
import org.springdm.service.FooService;

public class SpringDMClientActivator implements BundleActivator {
    public void start(final BundleContext bCtx) throws Exception {
        Thread t = new Thread(new Runnable(){
            boolean registered = false;
            ServiceReference ref = null;
            int safety = 0;
            public void run(){
                while (registered && safety < 10){
                    System.out.println("Trying to get the reference to FooService");
                    ref = bCtx.getServiceReference(FooService.class.getName());
                    if (ref != null){
                        break;
                    }
                    try {
                        Thread.sleep(100);
                    } catch (InterruptedException e) {
                    }
                    safety++;
                }
                if (ref == null){
                    System.out.println("Service " + FooService.class.getName() + " is not registered");
                } else {
                    System.out.println("Found service");
                    FooService service = (FooService) bCtx.getService(ref);
                    System.out.println("Retrieved service: " +
                        service.getClass().getName());
                    service.foo();
                }
            }
        });
        t.start();
    }

    public void stop(BundleContext bCtx) throws Exception {
        System.out.println("Stopping service");
    }
}
```

Now we have to define Activator in our MANIFEST file.
Open MANIFEST file → Click on Overview tab and let’s add `SpringDMClientActivator` we just created by clicking on Browse for Activator text field.

Click **OK** (save CTRL+S)
Verify that the entry was added by clicking on MANIFEST.MF tab.
This is it. Open **Run Dialog** and make sure SpringDMBundle and SpringDMBundleClient is selected

Click on **Run**

You should see the following output:

```log
org.apache.log4j: No appenders could be found for logger [org.springframework.util.ClassUtils].
org.springframework.util.ClassUtils: Please initialize the log4j system properly.
Trying to get the reference to FooService
Trying to get the reference to FooService
Trying to get the reference to FooService
>>> Constructing FooServiceImpl
Trying to get the reference to FooService
Trying to get the reference to FooService
Found service
Retrieved service: org.springframework.beans.FooServiceImpl
>>> Executing FooServiceImpl
```
And for the sanity check open **Run Dialog** again and uncheck **Target Platform**. By doing so you will un-deploy all Spring DM bundles. You Application Context will not be recognized and since no other facilities are provided do export FooService it will not be exported and our client SpringDMClientActivator won’t be able to locate it.

Here is the expected output

```
org.osgi> Trying to get the reference to FooService
Trying to get the reference to FooService
Trying to get the reference to FooService
Trying to get the reference to FooService
Trying to get the reference to FooService
Trying to get the reference to FooService
Trying to get the reference to FooService
Trying to get the reference to FooService
Trying to get the reference to FooService
Service org.springframework.service.FooService is not registered
```

### 11. Logging (log4j)

By now you probably annoyed with the following message popping up in your console every now and then

```
org.osgi:WARN No appenders could be found for logger [org.springframework.util.ClassUtils].
org.osgi:WARN Please initialize the log4j system properly.
```

I assume the reader knows what this mean, but how do we fix it within the scope of this tutorial?

Again there are several ways to do that. I am going to demonstrate one which follows the spirit of OSGi™ component architecture and it will also allow us to change logging configuration independently from the components that use logging services. This means we will not be creating and deploying log4j.properties file inside of any of the bundles that we have created.

Instead we will create a Fragment bundle which will contain our log4j.properties file and will be attached to the bundle providing logging services. The bundle that provides Log4j logging services inside of Spring DM Target Platform is org.springframework.osgi.log4j.osgi.
Let’s create another project. This time we will create Plug-in Development Environment (PDE) Fragment project that will contain log4j.properties file and will be attached to org.springframework.osgi.log4j.osgi bundle.

New → Other → Plug-in Development → Fragment Project → Next
Let’s name it Log4JProperties

Click Next. On the next window in the Host-plug-in area click on Browse and select org.springframework.osgi.log4j.osgi which is the bundle we are going to attach to.

Click OK → Finish (see below)
Create `log4j.properties` file at the root of the project

Here is what I have in my `log4j.properties` file

```
log4j.rootLogger=info, default
# default is set to be a ConsoleAppender.
log4j.appender.default=org.apache.log4j.ConsoleAppender
# default uses PatternLayout.
log4j.appender.default.layout=org.apache.log4j.PatternLayout
log4j.appender.default.layout.ConversionPattern=%d [%t] %-5p %c %x - %m%n
```

Nothing special
That is all we need.

Open **Run Dialog** and make sure the two bundles plus the **Log4jProperty** bundle is selected.

![Image showing the run dialog and selected bundles]

Click **Run** and your output should look similar to this:
Now you can change `System.out.println` in our bundles to use Log4j.

The benefit of this approach is that you don’t have to redeploy your services every time you want to change the logging levels. Simply redeploy the Log4JProperty Fragment bundle and restart `org.springframework.osgi.osgi` bundle.
12. Conclusion

Spring has been always branded as stateless container. With introduction of Spring DM for OSGi™ environment, not only you can make it state full, but you can introduce the concept of deploying and un-deploying beans (services) similar to the way we deploy WARs and EARs inside of Application Servers, but in a much lighter fashion. Bean(s) are still the same old POJOs that reside inside of Spring Application Context which is wrapped in OSGi™ bundle managed and supported by Spring Dynamic Modules. Such beans become services within OSGi™ container and can interoperate with one another as services in a true SOA fashion but without introducing the complexity of an ESB in the same way Spring addresses J2EE concerns without complexity of J2EE containers. No, OSGi is not an ESB, it is simply a light container for hosting bundles. However, with Spring Integration and Spring Web Services as OSGi™ bundles . . . could we possibly be looking at the light weight ESB based on Spring DM for OSGi™ Service platform. . .?